Rpg˛S Forum uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

Vai al contenuto

Rpg˛S Forum uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

 GUIDA AD ALTRI TOOL!! 
Rpg˛S Forum uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies


  • Si prega di effettuare il log in prima di rispondere
Metodo update "velocizzato" per le classi che includono Sprite

    Nintendomi
  • Nuovo Arrivato

  • Utenti
  • Rens: 0
  • 0
  • Stelletta
  • 26 messaggi

#1 Inviato 13 November 2016 - 23:32 PM

Parto dal principio! Come qualcuno avrà già letto in un'altra mia discussione, sto utilizzando uno script chiamato Galv's Invader come base per uno script, il quale funziona tranquillamente nel suo bel progetto.

 

Oggi, ho preso lo script e l'ho portato sul progetto di un mio amico, per il quale avevo appunto preparato tale script, ed è successa una cosa parecchio strana: tutti gli oggetti che vengono creati, che includono la classe Sprite (Nome_classe < Sprite) si muovono (tramite metodo update) a tipo il doppio della velocità rispetto a tutto il resto. L'unica altra classe che ha un qualcosa che "si muove" include Scene_Base e per l'appunto il suo tempo è rimasto uguale. Ora... su questo progetto ci hanno messo tante mani, il problema è che non so dove andare a vedere per trovare il problema.

 

La prima cosa che mi è venuta in mente è che, da qualche parte, qualcuno abbia sovrascritto Sprite facendo in modo che il metodo update aggiornasse più velocemente. Voi avete qualche idea su cosa potrebbe essere? Potrei se no eludere il problema impostando, in qualche modo io stesso, la velocità di update degli oggetti Sprite solo per il mio script? ...spero in qualche consiglio ^^" anche se so che non è facile parlarle senza avere sotto mano il progetto.


Modificato da Nintendomi, 13 November 2016 - 23:49 PM.


    KenzaMe92
  • Maker Svogliata

  • Utenti
  • Rens: 24
  • 2
  • StellettaStellettaStellettaStellettaStellettaStelletta
  • 1717 messaggi
  • Sesso:Femmina
  • Provenienza:Dalla strada a metā tra Immaginario e Fantasia
  • Abilitā:Esperto

#2 Inviato 14 November 2016 - 00:11 AM

Apri l'editor e vai su "Vocabs" poi fai CTRL+ALT+F e cerca 'Sprite' senza virgolette, dall'elenco, vedi gli script che sono stati aggiunti, che lo usano, e vedi se hanno la dicitura 'alias' prima del metodo che determina la velocità, se non è presente 'alias' vuol dire che lo sovrascrive

Inviato da mTalk con Lumia 550

00oVI6.gif SvsJAL.png  vgnoJt.png  YT3YHP.pngfcCbvW.pnggifnatale1.png
Come allegare immagini al forum     Bottega     Free Image Hosting Illimitato
 
 

869.png125d-620689e176026e435d815c752dbb99ec75erol.gif 1321.png
Script


Tutorial

Spoiler

    Nintendomi
  • Nuovo Arrivato

  • Utenti
  • Rens: 0
  • 0
  • Stelletta
  • 26 messaggi

#3 Inviato 14 November 2016 - 13:46 PM

Risolto!!  :biggrin: :smileright: :blush:

Praticamente c'era un'omonimia, per colpa della quale mi ridefiniva un medoto che veniva richiamato da update ^^ Grazie dell'aiuto


Modificato da Nintendomi, 14 November 2016 - 13:48 PM.


    KenzaMe92
  • Maker Svogliata

  • Utenti
  • Rens: 24
  • 2
  • StellettaStellettaStellettaStellettaStellettaStelletta
  • 1717 messaggi
  • Sesso:Femmina
  • Provenienza:Dalla strada a metā tra Immaginario e Fantasia
  • Abilitā:Esperto

#4 Inviato 14 November 2016 - 13:48 PM

di nulla :biggrin:


00oVI6.gif SvsJAL.png  vgnoJt.png  YT3YHP.pngfcCbvW.pnggifnatale1.png
Come allegare immagini al forum     Bottega     Free Image Hosting Illimitato
 
 

869.png125d-620689e176026e435d815c752dbb99ec75erol.gif 1321.png
Script


Tutorial

Spoiler




  • Feed RSS